+ Reply to Thread
Results 1 to 6 of 6

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Posts
    1

    Default Sulphur smell in water lines

    Earlier this year we replumbed our our whole house with PEX. We have three bathrooms, one on each floor. About 6-8 weeks ago we started getting a sulphur smell in the upstairs vanity water lines when we turned the water on. There is no smell in any other water line, including the toilet and shower in this bathroom. It's in both the cold and hot water lines. After running the faucet for about 30 seconds, the smell goes away. Do you have any idea what might be causing this?

  2. #2
    Join Date
    Oct 2008
    Posts
    5

    Default Re: Sulphur smell in water lines

    is PEX conneting the facet to the water line or a metal pipe because a metal pipe may have sulfur in them or it could be some kind of residue on the inside of the pipe hope this helps

  3. #3
    Join Date
    Aug 2008
    Posts
    35

    Default Re: Sulphur smell in water lines

    It can be caused by your hot water heater, do you have an electric hot water heater?

  4. #4
    Join Date
    Aug 2007
    Posts
    1,131

    Default Re: Sulphur smell in water lines

    Are you on a chlorinated city water supply or a non-chlorinated private well? If a non-chlorinated private well, do you know if there is any sulfur in your well water? Is there an iron content to the water?

    Did you replace the WH during the replumb of the house? If not, how old is the WH?

    Without knowing more, I'll offer this - It is possible that you have a minor-ish population of some sulfate reducing bacteria in your supply water. These bacteria can/will generate a certain amount of hydrogen sulfide gas (rotten egg odor results). It *may* be that the replumb allows/directs these tiny bubbles of this gas to wander up those particular PEX lines (when no water is drawn for long periods of time, such as overnight)....and consequently the odor is only present at this particular faucet.

    Without knowing more about your supply, WH situation, etc...it's difficult to make recommendations as to what approaches you should first try (the cheapest approaches) or what might be necessary to remedy the situation entirely.

    Also....if on a private well...do you have a bladder type pressure tank...or a galvanized single-compartment tank? (Assuming you don't have a variable speed well pump...in which case you might not have a pressure tank at all.)
    Last edited by goldhiller; 11-23-2008 at 10:54 AM.

  5. #5
    Join Date
    Nov 2008
    Posts
    14

    Default Re: Sulphur smell in water lines

    The easiest thing to make sure you have is a trap for the drain gasses! This could smell like sulfer but much more dangerous! It can make you sick literally to smell those gases! Good luck this is a very easy fix don't worry about it!

  6. #6
    Join Date
    Nov 2008
    Posts
    6

    Default Re: Sulphur smell in water lines

    I am having a similar problem. My wife and I bought our first place in March of this year. About a few weeks ago, we noticed a sulphur smell but it went away. Its been on and off for the past few weeks. This weekend when it appeared, I was able to trace it to the utility closet on our first floor.

    The water line from the ground splits when it enters our house. The left side is water that goes to the house and hot water heater and the right side passes through a double check valve and goes to the fire sprinkler system. There is a hose bib immediately after the check valve and I put my nose up to it and sure enough, sulphur. I turned off the main water supply valve and connected a hose to the bib and ran it outside and I drained the sprinkler system. There was a gauge that was reading 110 psi and I took it down to zero. When no water was flowing, I closed the bib, opened the supply valve, and repressured the system back to 110 psi. I then drained it again.

    The smell went away but it came back today. The house was built in 2000. I figured the smell was coming from water being trapped inside the sprinkler system for 8 years and never drained.

    I was reading up, and it seems the sulphur smell is a gas, so is it possible that its still in my pipes or is it from another source?

    Is there anything I can add to my water supply to absorb it or make it go away?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •