+ Reply to Thread
Results 1 to 3 of 3

Thread: Very SLOW drain

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Location
    Mansfield, OH
    Posts
    1

    Question Very SLOW drain

    When i start running the water in the tub it starts filling up quickly and if i shut the water off it takes 1/2hr to get it all down the drain. The plunger on the drain is up, but doesn't work anymore. I took off the overfill cap to see if the weight was still attached. It looks like a spring at the end of the thread. The house was built in 1959 and i am positive that all the fixtures are orignal. If anyone can help i would appreciate it. There are no markings on the faucet just says "made in the USA"

  2. #2
    Join Date
    Oct 2007
    Location
    NEAR SCRANTON, PA (YOU KNOW, WHERE THE OFFICE IS)
    Posts
    18

    Default Re: Very SLOW drain

    Quote Originally Posted by jliston View Post
    When i start running the water in the tub it starts filling up quickly and if i shut the water off it takes 1/2hr to get it all down the drain. The plunger on the drain is up, but doesn't work anymore. I took off the overfill cap to see if the weight was still attached. It looks like a spring at the end of the thread. The house was built in 1959 and i am positive that all the fixtures are orignal. If anyone can help i would appreciate it. There are no markings on the faucet just says "made in the USA"
    I know that with our bathtub when we have a problem with slow draining it is caused by a glob of hair getting stuck on the bars that go across the drain hole. When I say bars, it for lack of a better name. If you look in the drain hole, instead of just being a hole, there is a piece inside the drain that plug screws into. I noticed that it doesn't look like much of anything is clogging it, but if you get a pair of skinny pliers and pinch what is there you'll likely pull out a stinker.

    Good luck!

  3. #3
    Join Date
    Jun 2007
    Location
    Fayette County, Ohio
    Posts
    5,775

    Default Re: Very SLOW drain

    Quote Originally Posted by jliston View Post
    When i start running the water in the tub it starts filling up quickly and if i shut the water off it takes 1/2hr to get it all down the drain. The plunger on the drain is up, but doesn't work anymore. I took off the overfill cap to see if the weight was still attached. It looks like a spring at the end of the thread. The house was built in 1959 and i am positive that all the fixtures are orignal. If anyone can help i would appreciate it. There are no markings on the faucet just says "made in the USA"
    The spring is what actually pushes on the end of a finger on the plunger to move it up and down. You should be able to easily pull the plunger and the connected arm out of the drain to see if there is a clog of hair on it. If that and the spring are clean then the clog is further down the drain. You can try a snake down the overflow to see if you can clear it or if you have access to the trap from below remove it and check for it being clogged. If it is clear you will need to run a snake further down the line.
    Jack
    Be sure you live your life, because you are a long time dead.-Scottish Proverb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •