+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2009
    Posts
    1

    Default Attic ventilation is not working as intended.

    We live in Tucson, in a 37 yr old house,1 story, single family home. The attic space, between the flat roof and the interior ceilings, is 2ft at front of house and 9in at rear.

    At the front of our flat roof are small vents that come through the roof deck. At the rear, in the plywood panel between each roof joists, are 3 inch screen covered holes.

    Roof insulation is pushed up against the roof deck and secured between the joists. There is no ventilation space between the insulation and roof deck. As installed insulation does not allow air to enter the rear vent holes and flow along the underside of the roof deck (between the insulation and roof deck) and exit out the front roof vents.

    I have been told that the best thing to do now is block off all the vents (front and rear). Is this the appropriate thing to do.

    Thanks for your help.

  2. #2
    Join Date
    Mar 2009
    Posts
    1,387

    Default Re: Attic ventilation is not working as intended.

    Howdy the lack of air movement in the roof can cause mold issues and moisture issues and traps that good old Arizona sunshine heat in the attic. If your roof is worn i would consider having a cold roof installed. The rood gets 1"bys installed then plywood then new roofing membrane. This allows the roof to vent.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •