Hey everyone. My family has been living in our current house for just over two years now. This past summer, our carbon monoxide detectors went off one night, indicating a level in the 100's ppm. This has happened 2 more times since then, the most recent being last night. We've contacted several people to try and get an idea for the reason this is hapenning, but no one seems to know. Here's some of the facts:

House built in 1972
Has a radon fan built into the sump pump in the furnace room (in basement)
Furnace and hot water tank both vent to the same chimney, which uses a 6" flexible metal liner (insulated).
The first two times this happened, the furnace wasn't even active, being summer.
All three ocurrances seem to have been during somewhat 'stormy' weather. Last night it was rainy, 88% humidity, barometric pressure at 29.5 inches, and winds averaging 17mph gusting to 25 mph.

When it occurred last night, I checked the venting at the hot water tank, and sure enough, air was coming into the house, not going out. There's no overt blockage in the chimney (I was able to pass a line from one end to the other). So what would cause this? Downdrafts? Negative air pressure? Poor makeup air going into the furnace room, so it has nowhere else to draw from? More importantly, what in your minds would be the best fix? I also must state we've never cleaned the liner with a chimney sweep since we've moved here. We're considering doing so, but would that have so much of an impact, and only in specific conditions? We're also condering getting a special chimney cap to prevent downdrafts. Any other posibilities? Thanks for any input you can provide!!