+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2007
    Posts
    1

    Default inconsistent flush

    The toilet in the master bathroom is relatively new. American Standard 1.6. I have replaced the guts twice. Often times it will take 4 to 5 flushes to have the solid waste to down. It usually will just spin around and around. ( sorry, no music happens) When I plunge it goes down rapidly. Then the scene starts all over again.

  2. #2
    Join Date
    Oct 2007
    Posts
    1

    Default Re: inconsistent flush

    I've got the same problem with my new American Standard one-piece cadet. I lowered the float cup with the water level adjustment link and it seems to work better, not great, but better.

  3. #3
    Join Date
    Aug 2007
    Location
    Maryland
    Posts
    1,588

    Default Re: inconsistent flush

    we had new A.S. toilets installed in a new office that did the same thing. The plumber wasn't able to get them to work correctly.
    He eventually replaced them w/ Toto toilets that work well.

  4. #4
    Join Date
    Dec 2007
    Posts
    5

    Default Re: inconsistent flush

    I have an old warhorse A.S. onepiece from 1979.

    Lately had the same problem. the flapper wasn't coming up all the way obstructing the vent. I made the chain going to it a notch or two shorter, problem solved. BA woosh as it should .... hope this might help...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •