+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2014
    Posts
    2

    Default Boiler not heating

    Hello I need some help trying to figure out why my boiler is not heating and or circulating the hot water.
    I have bled the system to get out any air. The main feed line gets extremly hot but the rest are either luke warm or cold.
    Can this be from a bad circulator pump?
    Any help would be appercialed. Winter is not the time to not have heat...

  2. #2
    Join Date
    Sep 2012
    Location
    Boston
    Posts
    820

    Default Re: Boiler not heating

    sounds like a bad circulator pump or air in the system to me. when you bleed each radiator make sure you fill up at least one cup of water.

  3. #3
    Join Date
    Jul 2009
    Posts
    137

    Default Re: Boiler not heating

    Sounds like a bad pump---you need to call your local heating service person ASAP to get the HW circulating again.

    Please post back with the results after the service person leaves.

  4. #4
    Join Date
    Jan 2014
    Posts
    2

    Default Re: Boiler not heating

    Sorry for the delay in responding to your suggestions gentleman, but 9" of snow and sub zero temps we have heat!!!
    Yes I did install a new pump, but it turns out that the hot water thermostat was turned up higher than the heating water thermostat. There for it was not recognizing the call for heat. Yes my Weil-Mclain does both the domestic hot water and heating hot water. We are nice and toasty again.
    Thanks, RobD133

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •