+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2012
    Posts
    2

    Default thermostat malfunction

    The room temperature rises on my honeywell 8500 thermostat when the backlight(feature 280) is on. The dim light works, the bright light lasts for 8 seconds. If I turn off the feature and the stat is dark the temperature is correct. Turn on the dim light and temp will rise 3 or 4 degrees in less than an hour. Is this the wiring, the current or voltage or what? This is the second thermostat i have used, then first one was ruined, it is a new Trane 13 heat pump and my installers are stumped. Need some help please.

  2. #2
    Join Date
    Jul 2010
    Location
    SoCal
    Posts
    5,081

    Default Re: thermostat malfunction

    The thermostat is probably defective.

    High price doesn't always deliver high quality. Ask your installer to give you a non-programmable unit.

    This is another reason I never install programmable thermostats.

  3. #3
    Join Date
    Oct 2012
    Posts
    2

    Default Re: thermostat malfunction

    Thanks for the info, I will go with non programmable one, I never use the programs anyway. I just wanted the backlight and cycle features. Thanks again, my installer is calling Honeywell and I am waiting for next info.

  4. #4
    Join Date
    Jul 2010
    Location
    SoCal
    Posts
    5,081

    Default Re: thermostat malfunction

    Quote Originally Posted by Stepone23 View Post
    Thanks for the info, I will go with non programmable one, I never use the programs anyway. I just wanted the backlight and cycle features. Thanks again, my installer is calling Honeywell and I am waiting for next info.
    There are a dozen or more brands of what you need, with lights, for under $30. Some are under $20.

    When changing over, don't mess up the wires.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •