+ Reply to Thread
Results 1 to 5 of 5
  1. #1

    Default Smith gb100w boiler ignitor doesn't heat up

    I have a Smith Cast Iron Boiler Model# GB100W. I went to test the boiler and it wouldn't work. I changed the ignitor but it still doesn't work. The ignitor is not heating up when the thermostat calls for heat. It goes through all the motions but won't turn on because the ignitor isn't heating up. Then it shuts down the system until I reset. Thanks for your help in advance. Jim F

  2. #2
    Join Date
    Jul 2010
    Location
    SoCal
    Posts
    6,498

    Default Re: Smith gb100w boiler ignitor doesn't heat up

    If your ignitor gets the signal but fails to glow/heat up, it's probably defective. Replace it with the same kind, making sure that the new one is positioned in the exact same spot.

  3. #3

    Default Re: Smith gb100w boiler ignitor doesn't heat up

    I have changed it with three new ingnitors. None of them fire up. When it calls for heat it goes through the cycle but it won't heat up. Thanks for the reply !

  4. #4

    Default Re: Smith gb100w boiler ignitor doesn't heat up

    I have changed the thermostat,rollout switch,spill switch and the vent damper to no avail. The system goes through the motion but the ignitor won't heat up at all. Any suggestions would be appreciated. Thanks in advance, Big Jim

  5. #5
    Join Date
    Nov 2011
    Posts
    51

    Default Re: Smith gb100w boiler ignitor doesn't heat up

    I wouldn't say it's an ignitor issue (well it is, because it isn't heating up, obviously) but more of a relay issue. just think about that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •