+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Join Date
    May 2011
    Posts
    1

    Default Circuit Not Working

    I have a circuit that has 2 outlets and an overhead light on it. I noticed the other day that neither of the outlets, nor the overhead light are working. I checked the breaker and it hasn't tripped, so I'm trying to determine what happened. I do recall that a keyborad was plugged into one of the outlets and ever since then the outlet seemed to only work intermittantly - but now nothing is working. Could the keyborad have caused this?Any advice on fixing this would be appreciated.

  2. #2
    Join Date
    Jul 2010
    Location
    SoCal
    Posts
    6,312

    Default Re: Circuit Not Working

    Go back to the panel and reset the breaker again, making sure it goes all the way to "on" position.
    Some breakers stick, some have two step on position. Some may look good, but they could be bad.
    If still no power, replace the breaker. If you can't do it, don't kill yourself, call a pro.

  3. #3
    Join Date
    Jun 2007
    Location
    Fayette County, Ohio
    Posts
    5,774

    Default Re: Circuit Not Working

    First check to see if you have a GFCI tripped on that circuit.

    After trying the breaker, check the outlets to see if the wires are in the stab connection rather than on the screws.

    Jack
    Be sure you live your life, because you are a long time dead.-Scottish Proverb

  4. #4
    Join Date
    Dec 2010
    Location
    Houston Texas
    Posts
    2,917

    Default Re: Circuit Not Working

    To add some more to what DJ said-

    Turn the breaker all the way off, then all the way on. Some breakers have a middle position that is hard to visually detect.

  5. #5
    Join Date
    Feb 2011
    Location
    Brown county, Ohio
    Posts
    52

    Default Re: Circuit Not Working

    I had something like this before at my parents house, what had happened there is the neutral screw had backed out and the wire was not touching, and of course no electric, thier house was about 10 years old at the time. unlikely but possible, may want to check those and make sure they are all tight. but first i agree with the others... turn it all the way off and then back on. good luck and be safe

  6. #6
    Join Date
    Jan 2011
    Location
    Columbiana, Alabama
    Posts
    692

    Default Re: Circuit Not Working

    Ditto to Jack & Edgeking. Got a call to a mega-buck mansion yesterday for the same thing. Got crazy lights on my $9 tester in all the receptacles. But, if I wiggled the tester at one the room power was restored.

    There I found a melted receptacle that fed the rest of the room. Two of the wires were wrapped counter-clockwise around the screws. The other two were back-stabbed and the two ground wires were both wrapped around the ground screw. All, IMO are signs of a hacker (and will probably be found throughout the house).

    Back-stabbing is still legal, in most places, with #14 wire, but causes more problems than any other item I know of.

    Good Luck from Columbiana, Alabama
    Maurice Turgeon http://thesemi-retiredelectrician.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •