+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2009
    Posts
    4

    Default Steam heating system-losing steam

    I have a steam heating system. Last winter, it would lose steam consistently during heating season. I'd have to refill it once a day. I changed all of the air vents last year to the 'tall' cylinders--larger upstairs, smaller ones down stairs using the advice from the local hardware store. No effect on steam loss. I could hear them hiss and then click shut reliably.

    Recently I had the unit looked at for a different reason and mentioned the loss of steam in the cold months. The repairman did not see any rust on the boiler, nothing obvious around the base of the unit.

    I bought some new air vents this weekend-'Maid o Mist'--more of a drum style than the tall cylinders. Not much change. One radiator with the new Maid O Mist just kept putting out steam with no shut off (this one is closest to the furnace). The air vent appeared like all the others that hissed/shut off (although it took longer for these to shut off than the tall cylinder type).

    There were two units last year that were leading at the turn off valve--fixed that with graphic rope.

    Before I call the repair man back, what else can I look for and fix as a home repair person? There is no indication of wet ceilings/floors that I can see.

    Any other ideas or is this a job for a professional?

    Thanks!

  2. #2
    Join Date
    Feb 2010
    Location
    South*East
    Posts
    1,183

    Default Re: Steam heating system-losing steam

    How old is the boiler? Is there any section of the piping that may be out of sight in a crawl space or something? A leak in the upper part of the boiler would not show up as a water leak. There is also a relief valve on the system that can also be releasing steam. If you had to repack two valves I would take a close look at the rest of them.

    John

  3. #3
    Join Date
    Nov 2009
    Posts
    4

    Default Re: Steam heating system-losing steam

    thanks John,

    I just bought the house in January 2010. It passed the inspection with some minor changes. But we were not in the house long enough to detect any excessive steam loss. Guessing the boiler is less than 10 yrs old--probably even less than that.

    The work the repair man did was to install a new mixing valve and there was a corresponding valve he had to replace with that process. He said the boiler did not have rust on it--so while I was not in the basement when he did the work, guessing that he had to open up the sides to see in side. I had also had someone in to quote converting to gas and mentioned it to him and he said he didn't notice anything on the outside that indicated that the loss was coming from the main mechanism--recommended changing the radiator air vents--which I did as mentioned.

    Sounds like a job for a more experienced person.

    Thanks John.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •