+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2008
    Posts
    6

    Default Overhead Microwave not venting enough

    After a remodel, done by contractor, in which I had an over stove microwave put in, I'm finding it's not venting well at all.

    Microwave, bought almost 3 yrs ago but never used due to waiting for the remodel.... is a Whirlpool g2 microven model GH178XPS - was close to the top of the Whirlpool line w/ quartz and halogen grilling, touchscreen, etc... seems like it should vent decently.

    The Set up is for exterior vent. When items are on rear burners - a lot of the steam/smoke/etc.. is caught but a fair quantity goes on sides of microwave. When front burners are used - almost no steam etc gets vented - instead almost all of it wraps up the fron of microwave drenching it in condensation over entire face - I'm worried this will eventually (it's all new) damage the cherry cabinets above - not to mention damage to ceiling and coat of grease over most everything.

    I'm wondering if this is all I can expect from a microwave vrs a specialized vent hood - though I seem to recall seeing this type of microwave setup vent fine elsewhere - not sure though.

    When turning fan on high, starting two pots boiling water on the back burners - and it being somewhat cold outside (I'm in south florida... it's not too cold) I can't see any steam at all escaping from roof vent.

    Wondering if they might have installed the damper assembly incorrectly.

  2. #2
    Join Date
    Jan 2009
    Location
    Staten Island, NY
    Posts
    11

    Lightbulb Re: A lot could be wrong. . . . . . . .

    First thing I'd do is take some tissue paper and hold it up to the grease filters and see if it sticks to it with the vent on. If that works try a paper towel next. This will at least let you know if the blower motor is function properly.

    If you have good exhaust, the damper may be hitting the extension coller as it try's to open fully, or the vent may have not be connected correctly to begin with. Also the run fro where the exhaust starts to where it exits the house may be to far of a run. The installer may have used to many 90 elbows. . .

    Lastly the venting pipe may be to small, most people use 4" where 6 or 8" would be better.

    Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •